屏蔽XShell/Xftp 5强制升级,解决XShell/Xftp 5不可用的脚本分享

对于习惯用XShell/Xftp 5来控制vps的朋友来说,这两天应该碰到了强制升级到XShell/Xftp 6的情况,对于不喜欢升级到XShell/Xftp 6的朋友,可以通过下面的脚本来实现禁止XShell/Xftp 5强制升级功能。

948d281cgy1fillaj0gf7j20ks0ght97 570x452 Xftp 5.0.1235 绿色版 免费FTP/SFTP客户端 免费 Xftp SFTP FTP

如果你的XShell/Xftp 5没有碰到强制升级提示,那么恭喜你,你用的是国内流氓公司代理的版本,并非纯净原版XShell/Xftp 5。

屏蔽XShell/Xftp 5强制升级脚本来源:

https://github.com/DeepSkyFire/XShell5-Startup-Script

脚本请自行到上面网址下载,如果不会下载的 点这个连接 或 网盘下载

使用方法很简单,把下载下来的bat文件放到XShell/Xftp 5的安装目录,然后管理员身份运行,输入对应格式的日期就可以了。

如启动失败请自行查看xshell.exe/xftp.exe的详细内容内的数位签章的时间戳记,并将脚本内的“25-12-2018”按此格式改为数位签章内的时间戳记录的时间。

如果你想更安稳的使用XShell5/Xftp5的话,你还可选择在HOSTS内添加以下内容防止XShell5/Xftp5自动升级:

127.0.0.1 transact.netsarang.com
127.0.0.1 update.netsarang.com
127.0.0.1 www.netsarang.com
127.0.0.1 www.netsarang.co.kr
127.0.0.1 sales.netsarang.com

手动接触时间强制升级限制的方法

ddosworks大佬给出的修改方法,很简单,比上面的脚本似乎更好用,修改也简单,方法如下:

找个反汇编软件C32asm就可以(我测试这个软件搜索不到内容,直接用ultraedit 搜索替换也可以)
打开nslicense.dll
搜索16进制
7F0C81F98033E1010F8680
修改为
7F0C81F98033E101E98100
修改为
7F0C81F98033E1010F8380
都可以

附上修改好的
https://anonfiles.com/S7o5I7o2b1/nslicense_dll

度盘 完整的
https://pan.baidu.com/s/1T1xA3FshzzR1_jQsIowa4Q

最后你也可以使用 Xshell 6.0.0.109 中文绿色版 - 支持多窗口管理Linux等终端的软件

打赏 赞(0)
微信二维码图片

微信扫描二维码打赏

1 条评论

  1. 第一步:
    下载对应的版本
    Xshell-5.0.1339 注册版 https://download.netsarang.com/f9c47326/Xshell-5.0.1339r.exe
    Xshell-6.0.0109 注册版 https://download.netsarang.com/f9c47326/Xshell-6.0.0109r.exe
    复制代码

    第二步:
    修改 hosts 文件,加入以下内容(把 / 去掉,论坛屏蔽了)
    127.0.0.1 transact.netsarang.com
    127.0.0.1 update.netsarang.com
    127.0.0.1 w/w/w.netsarang.com
    127.0.0.1 w/w/w.netsarang.co.kr
    127.0.0.1 sales.netsarang.com

    第三步:
    安装,然后注册
    Xshell-5.0.1339 注册码 181226-111351-999033
    Xshell-6.0.0109 注册码 181226-111725-999177

发表评论